Здравствуйте, гость ( Вход | Регистрация )



 
Ответить в данную темуНачать новую тему
> 100 Мбит UA-IX и 3 МБит в Мир + Mikrotik, Как научить Микротик правильно шейпить канал?
Romeo
сообщение 8.9.2008, 11:12
Сообщение #1


Бит
*

Группа: Пользователи
Сообщений: 3
Регистрация: 7.9.2008
Пользователь №: 5409
Спасибо сказали: 0 раз




Ребя есть проблемка, прошу помощи в решении.
Имеется оптоволоконный канал 100 мегабит Украинского тарфа и 3 мегабита канал в мир (включенный в комп с Микротиком) и в этот же комп подключена локалка.
Микротик 2.9.6

Вопрос:
Как обучить Микротик, чтобы я мог конкретному юзеру указывать скорость в мир и скорость в Украину?

Когда канал был общий 2 Мегабита общего трафа, было проще. Указывал просто максимальную скорость для клиента и все было и честно и правильно и шейпер работал.
Счас решил поменять на тариф 100\3
Теперь ограничение канала в 1 мегабит дает юзеру право качать как с Украины так и с Мира на скорости 1Мбит.

Понимаю что вариант решения в диапазоне IP адресов (который у меня есть) Есть зона IP - UA-IX т есть остальные IP которые считаются как "Мир"

Помогите хотя бы идею создать, а лучше еще и на практике воплотить вариант решения этой задачки
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Гость_nickolayenko_*
сообщение 11.12.2008, 11:16
Сообщение #2





Гости







Цитата(Romeo @ 8.9.2008, 11:12) *
Ребя есть проблемка, прошу помощи в решении.
Имеется оптоволоконный канал 100 мегабит Украинского тарфа и 3 мегабита канал в мир (включенный в комп с Микротиком) и в этот же комп подключена локалка.
Микротик 2.9.6

Вопрос:
Как обучить Микротик, чтобы я мог конкретному юзеру указывать скорость в мир и скорость в Украину?

Когда канал был общий 2 Мегабита общего трафа, было проще. Указывал просто максимальную скорость для клиента и все было и честно и правильно и шейпер работал.
Счас решил поменять на тариф 100\3
Теперь ограничение канала в 1 мегабит дает юзеру право качать как с Украины так и с Мира на скорости 1Мбит.

Понимаю что вариант решения в диапазоне IP адресов (который у меня есть) Есть зона IP - UA-IX т есть остальные IP которые считаются как "Мир"

Помогите хотя бы идею создать, а лучше еще и на практике воплотить вариант решения этой задачки



Когда искал как настроить шейпер, наткнулся в гугле какойто зарубежный форум, там половина общается на латвийском половина на русском, в общем там был приведён пример как разделить трафик на зарубежный и литовский. Ищи, может найдёшь.
В принцыпе самого нтересует данный вопрос, если кто то найдёт или реализует данную задачу пожалуйста отпишитесь, довольно интересный и нужный вопрос.
Заранее благодарен
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Romeo
сообщение 11.12.2008, 18:34
Сообщение #3


Бит
*

Группа: Пользователи
Сообщений: 3
Регистрация: 7.9.2008
Пользователь №: 5409
Спасибо сказали: 0 раз




Мне уже один добрый человек помог. Правда идея реализации на самом микротике кривовато получается. На данный момент у меня в Микротик надо загонять скриптом вручную список сетей UA-IX, потом маркируются пакеты, а поотом создаются очереди...
Вобщем это все отлично работает, только один минус, что надо обновлять вручную списки UA-IX.
Но если поднять биллинг, то тот же умный человек мне сказал, что это все можно реализовать автоматически. Пока что все работает так как есть, но в течени месяца планируем все сделать по правильному.

А шейпер на Украину и мир отрабатывает отлично!!
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Гость_nickolayenko_*
сообщение 25.12.2008, 12:51
Сообщение #4





Гости







Цитата(Romeo @ 11.12.2008, 18:34) *
Мне уже один добрый человек помог. Правда идея реализации на самом микротике кривовато получается. На данный момент у меня в Микротик надо загонять скриптом вручную список сетей UA-IX, потом маркируются пакеты, а поотом создаются очереди...
Вобщем это все отлично работает, только один минус, что надо обновлять вручную списки UA-IX.
Но если поднять биллинг, то тот же умный человек мне сказал, что это все можно реализовать автоматически. Пока что все работает так как есть, но в течени месяца планируем все сделать по правильному.

А шейпер на Украину и мир отрабатывает отлично!!



Будь добрым человеком smile.gif Поделись идейкой nickolayenkonick@bigmir.net или ICQ:310-218-703
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Гость_Гость_Виталий_*_*
сообщение 27.11.2013, 15:08
Сообщение #5





Гости







Можно подробнее.... Версия микротик 5.18 в адреслист скрипт добавляет сети уаикс. Не получается делить... Подскажите плиз.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Zhelezaka
сообщение 8.12.2013, 2:57
Сообщение #6


HD DVD
*****

Группа: Главные администраторы
Сообщений: 5442
Регистрация: 2.12.2005
Пользователь №: 7
Спасибо сказали: 421 раз




Цитата(Гость_Гость_Виталий_*_* @ 27.11.2013, 15:08) *
Можно подробнее.... Версия микротик 5.18 в адреслист скрипт добавляет сети уаикс. Не получается делить... Подскажите плиз.

Пакеты маркеруются? Что делал? Скрипты в студию ))


--------------------
Профессионал - тот же дилетант, только знающий, где ошибается.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Гость_Гость_Виталий_*_*
сообщение 10.12.2013, 18:05
Сообщение #7





Гости







Цитата(Zhelezaka @ 8.12.2013, 2:57) *
Пакеты маркеруются? Что делал? Скрипты в студию ))

Дело в том, что неполучается в мангл настроить. Не могу понять как правильно маркировать...

Скрипт на адрес лист:

Код
##################################
##          Starting UA-IX Script
##################################
:log info "Starting UA-IX Script...";
##          Deleting last address-list
##################################
:log info "Deleting last address-list...";
                /ip firewall address-list remove [/ip firewall address-list find list=ua-ix]
:delay 2
##          Download pieces.txt
##################################
:log info "Download pieces.txt...";
                /tool fetch url="http://ds7.net.ua/out/pieces.txt"
:delay 2
##          Download output
##################################
                :global prfend 0
                :global prfxses [/file get [/file find name=pieces.txt] contents];
                :global prfxses ($prfxses - 1);
                :for col from=$prfend to=$prfxses do={
                               :log info "Download output$prfxses.txt...";
                               /tool fetch url="http://ds7.net.ua/out/output$prfxses.txt";
                               :set prfxses ($prfxses - 1);}
:delay 5
##          Creating address list ua-ix
##################################
                :global prfend 0
                :global prfxses [/file get [/file find name=pieces.txt] contents];
                :global prfxses ($prfxses - 1);
:delay 2
                :for a from=$prfend to=$prfxses do={
                               :local content [/file get [/file find name="output$prfxses.txt"] contents];
                               :global contentLen [ :len $content ];
                               :global lineEnd 0;
                               :global line "";
                               :global lastEnd 0;
                                               :Do {
                                                               :set lineEnd [:find $content "\n" $lastEnd ];
                                                               :set line [:pick $content $lastEnd $lineEnd];
                                                               :set lastEnd ( $lineEnd + 1 );
                                                               :if ( [:pick $line 0 1] != "#" ) do={
                                                                              :local entry [:pick $line 0 ($lineEnd -1) ]
                                                                              :if ( [:len $entry ] > 0 ) do={
:log info "Creating address $entry...";
                                                                                              /ip firewall address-list add list=ua-ix address=$entry
                                                                                              }
                                                                              }
                                                               } while ($lineEnd < $contentLen);
                               :set prfxses ($prfxses - 1);}
                }
:delay 5;
                :global prfend 0
                :global prfxses [/file get [/file find name=pieces.txt] contents];
                :global prfxses ($prfxses - 1);
:delay 2;
:if ($prfxses > 0) do={
                               /file remove pieces.txt
                               :for col from=0 to=$prfxses do={/file remove "output$prfxses.txt"
                               :set prfxses ($prfxses - 1);}
                               } else={
                :log info "File not Found";}
:log info "The Script is done...";
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Zhelezaka
сообщение 10.12.2013, 23:51
Сообщение #8


HD DVD
*****

Группа: Главные администраторы
Сообщений: 5442
Регистрация: 2.12.2005
Пользователь №: 7
Спасибо сказали: 421 раз




Цитата
Дело в том, что неполучается в мангл настроить. Не могу понять как правильно маркировать...


К примеру, address-list с именем к примеру UA:

Код
add address=8.8.4.0/24 comment="" disabled=no list=UA
add address=8.8.8.0/24 comment="" disabled=no list=UA
....
add address=217.196.160.0/20 comment="" disabled=no list=UA
add address=217.199.224.0/20 comment="" disabled=no list=UA


Можно делать address-list любыми способами, к примеру предложенный вами.

Далее маркируем
Код

/ip firewall mangle
add action=mark-routing chain=prerouting comment=UA-IX disabled=no \
dst-address-list=UA new-routing-mark=UA passthrough=no
add action=mark-routing chain=prerouting comment=Word disabled=no \
dst-address-list=!UA new-routing-mark=UA passthrough=no


Далее Route List указываем маршруты куда необходимо

Маркировка пакетов с помощью Mangle в Mikrotik
Обновление списка сетей внутрестраны MikroTik


--------------------
Профессионал - тот же дилетант, только знающий, где ошибается.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Гость_Гость_Виталий_*_*
сообщение 11.12.2013, 23:16
Сообщение #9





Гости







Цитата(Zhelezaka @ 10.12.2013, 23:51) *
К примеру, address-list с именем к примеру UA:

Код
add address=8.8.4.0/24 comment="" disabled=no list=UA
add address=8.8.8.0/24 comment="" disabled=no list=UA
....
add address=217.196.160.0/20 comment="" disabled=no list=UA
add address=217.199.224.0/20 comment="" disabled=no list=UA


Можно делать address-list любыми способами, к примеру предложенный вами.

Далее маркируем
Код

/ip firewall mangle
add action=mark-routing chain=prerouting comment=UA-IX disabled=no \
dst-address-list=UA new-routing-mark=UA passthrough=no
add action=mark-routing chain=prerouting comment=Word disabled=no \
dst-address-list=!UA new-routing-mark=UA passthrough=no


Далее Route List указываем маршруты куда необходимо


В винбоксе создаю:

/ip firewall mangle
add action=mark-routing chain=prerouting comment=ua-ix disabled=no \
dst-address-list=ua-ix new-routing-mark=ua-ix passthrough=no
add action=mark-routing chain=prerouting comment=Word disabled=no \
dst-address-list=!ua-ix new-routing-mark=World passthrough=no

Правильно?

Далее Route List Как тут правильно указать маршрут? У меня там айпишки сетевые уже есть прописаны или то не то?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Zhelezaka
сообщение 13.12.2013, 3:11
Сообщение #10


HD DVD
*****

Группа: Главные администраторы
Сообщений: 5442
Регистрация: 2.12.2005
Пользователь №: 7
Спасибо сказали: 421 раз




Цитата(Гость_Гость_Виталий_*_* @ 11.12.2013, 23:16) *
Далее Route List Как тут правильно указать маршрут? У меня там айпишки сетевые уже есть прописаны или то не то?


Можно просто указать, что все что не UA - идет на default интрефейс (VLAN1/ether1), что в "мир", а остальное в тот интрефейс (VLAN2/ether2), что UA.

Вот на форуме подсмотрел пример:

IP роутера - 19.23.24.1 (блока его автономки 19.23.24.0/23)
IP провайдера по UA-IX 9.15.9.89
IP провайдера по Мир 93.24.33.17


по UA-IX все что приходит получает больший вес чем то, что в "мир".

Код
/routing filter
add action=passthrough chain=WORLD-IN disabled=no invert-match=no \
    set-bgp-local-pref=100 set-bgp-weight=100
add action=accept chain=WORLD-IN disabled=no invert-match=no \
    set-bgp-local-pref=100 set-bgp-weight=100
add action=accept chain=WORLD-OUT disabled=no invert-match=no prefix=\
    19.23.24.0/23
add action=discard chain=WORLD-OUT disabled=no invert-match=no
add action=accept chain=UA-IX-IN disabled=no invert-match=no set-bgp-local-pref=\
    1000 set-bgp-weight=1000

/routing bgp instance
add as=42595 client-to-client-reflection=no disabled=no ignore-as-path-len=no \
    name=Provider out-filter=WORLD-OUT redistribute-connected=yes \
    redistribute-ospf=no redistribute-other-bgp=no redistribute-rip=no \
    redistribute-static=yes router-id=19.23.24.1 routing-table=""

/routing bgp peer
add address-families=ip as-override=no default-originate=never disabled=no \
    hold-time=3m in-filter=UA-IX-IN instance=Soniko multihop=no name=UA-X \
    nexthop-choice=default out-filter=WORLD-OUT passive=no remote-address=\
    9.15.9.89 remote-as=12773 remove-private-as=no route-reflect=no \
    tcp-md5-key="" ttl=default use-bfd=no

add address-families=ip as-override=no default-originate=never disabled=no \
    hold-time=3m in-filter=WORLD-IN instance=Soniko multihop=no name=World \
    nexthop-choice=default out-filter=WORLD-OUT passive=no remote-address=\
    93.24.33.17 remote-as=12773 remove-private-as=no route-reflect=no \
    tcp-md5-key="" ttl=default use-bfd=no

/routing bgp network
add disabled=no network=19.23.24.0/23 synchronize=no


--------------------
Профессионал - тот же дилетант, только знающий, где ошибается.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

Свернуть

> Похожие темы

  Тема Ответов Автор Просмотров Последнее сообщени
Нет новых сообщений Настройка MikroTik+L2TP
VPN - l2tp, маленькая скорость
1 blhleha 1684 22.3.2016, 11:16
Посл. сообщение: Zhelezaka
Нет новых сообщений Mikrotik. Два шлюза в одной сети
Помогите разобраться пожалуйста
2 dinar921928 3600 29.9.2015, 7:25
Посл. сообщение: dinar921928
Нет новых В теме есть приложенияMikrotik. Вопросы и ответы
помощь в настройке
1047 dolphinik 402837 3.7.2012, 16:31
Посл. сообщение: -Гость-
Нет новых сообщений Реализация трафик-шейпера (Traffic Shaper) на Mikrotik
скрипт для динамического и ровного деления скорости
11 Zhelezaka 31532 2.3.2012, 3:42
Посл. сообщение: Zhelezaka
Нет новых сообщений В теме есть приложенияНе конектится к Mikrotik 750GL
Не могу зайти в настройки
1 gansterd 4827 19.12.2011, 0:34
Посл. сообщение: Zhelezaka


 



RSS Текстовая версия Сейчас: 26.5.2017, 23:47